Search found 484 matches

by BasicScience
Jan 03, 2020 0:34
Forum: Libraries
Topic: disphelper.a FB-1.07.1-win64
Replies: 3
Views: 241

Re: disphelper.a FB-1.07.1-win64

Thanks for the offer. Unfortunately I don't have mingw 64 bit installed.
by BasicScience
Dec 31, 2019 18:41
Forum: Libraries
Topic: disphelper.a FB-1.07.1-win64
Replies: 3
Views: 241

Re: disphelper.a FB-1.07.1-win64

My prior post wasn’t very clear.

I’m trying to find disphelper.a that is compatible with FB-1.07.1-win64. Does anyone know of an available download?
by BasicScience
Dec 31, 2019 2:43
Forum: Libraries
Topic: disphelper.a FB-1.07.1-win64
Replies: 3
Views: 241

disphelper.a FB-1.07.1-win64

Has anyone recompiled the disphelper library for win64?

I verified the (old) win 32 bit version works with FB-1.07.1-win32.
by BasicScience
Dec 31, 2019 2:25
Forum: General
Topic: [SOLVED] Undefined Reference with xFont FB-1.07.1
Replies: 11
Views: 343

Re: [SOLVED] Undefined Reference with xFont FB-1.07.1

@badidea,

Many thanks. Verified everything works on win32 and win64.
by BasicScience
Dec 28, 2019 22:41
Forum: General
Topic: [SOLVED] Undefined Reference with xFont FB-1.07.1
Replies: 11
Views: 343

Re: [SOLVED] Undefined Reference with xFont FB-1.07.1

@ Badidea, thanks. You might also consider fixing an annoying bug in xFont. The LoadFont function always closes file #1 instead of using FreeFile to identify an open file #. This glitch can be difficult to track down when your project is experiencing unexpected closures of File #1.
by BasicScience
Dec 28, 2019 15:27
Forum: Libraries
Topic: xfont complie error
Replies: 4
Views: 3496

Re: xfont complie error

I had the same problem with FB-1.07.1. The error was fixed by recompiling the xfont library.
by BasicScience
Dec 27, 2019 18:03
Forum: General
Topic: [SOLVED] Undefined Reference with xFont FB-1.07.1
Replies: 11
Views: 343

Re: [SOLVED] Undefined Reference with xFont FB-1.07.1

Indeed, recompiling the library with the 1.07.1 version of FBC solved the problem. Others may want to use xfont, but the source code is needed to recompile the library. LeonHeart made the source public, but the URL is no longer active. I would be happy to share the code. Perhaps someone can post it ...
by BasicScience
Dec 27, 2019 16:18
Forum: General
Topic: [SOLVED] Undefined Reference with xFont FB-1.07.1
Replies: 11
Views: 343

Re: Undefined Reference with xFont FB-1.07.1

Yes, the library was created in 2010. That said, I thought "old" libraries were backward compatible with Win-32 versions of the compiler.
by BasicScience
Dec 27, 2019 8:46
Forum: General
Topic: [SOLVED] Undefined Reference with xFont FB-1.07.1
Replies: 11
Views: 343

[SOLVED] Undefined Reference with xFont FB-1.07.1

I have used xFont by LeonHeart for years, up through FB-1.03.0 for Win. Today, I finally upgraded to FB-1.07.1 and now I get a compiler error undefined reference to 'XFONT::INTERFACE::FORECOLOR__SET__(unsigned long)@8' whenever I try to set the ForeColor as shown in the code below. The same problem ...
by BasicScience
Aug 11, 2019 22:31
Forum: Community Discussion
Topic: Print Screen Command?
Replies: 3
Views: 3690

Re: Print Screen Command?

I just save the screen to a BMP file. You can the print, edit, or perform any other modification.

Code: Select all

BSave "ScreenShot.BMP", 0
by BasicScience
Jun 02, 2019 16:06
Forum: Projects
Topic: FBIde 0.4.6 r3 Avilable now
Replies: 83
Views: 41490

Re: FBIde 0.4.6 r3 Avilable now

Thanks for the suggestions. I got FBIde to work again, after a clean boot. (See comments under Community Discussion). So, it appears to have been a conflict with other software (most likely antivirus) rather than a problem with an out of date dll.
by BasicScience
Jun 02, 2019 16:02
Forum: Community Discussion
Topic: What IDE are you using?
Replies: 5
Views: 3353

Re: What IDE are you using?

Thanks for the suggestions. I did a clean boot (disabled all MS Services and all applications in the Start-up), and now FBIde is working again. I have enabled all the MS Services and FBIde still works, so it must be a conflict with some application in the start-up. There are lots of possibilities (S...
by BasicScience
Jun 02, 2019 3:32
Forum: Community Discussion
Topic: What IDE are you using?
Replies: 5
Views: 3353

What IDE are you using?

I have used FBIde for > 10 years and love(d) it. Suddenly I can't launch the application because of an error message on Win10 64-bit "The application was unable to start correctly (0xc0000142)". It had been about 2 months since I launched FBIde, so it could be difficult to determine whethe...
by BasicScience
Jun 02, 2019 3:04
Forum: Projects
Topic: FreeBASIC IDE with enhanced debugging and project features
Replies: 47
Views: 20143

Re: FreeBASIC IDE with enhanced debugging and project features

How can I set that path for custom INC files (with *.BAS files in subfolders, just like the FBC/INC folder)?
by BasicScience
Jun 02, 2019 2:04
Forum: Projects
Topic: FBIde 0.4.6 r3 Avilable now
Replies: 83
Views: 41490

Re: FBIde 0.4.6 r3 Avilable now

FBIde will no longer start. Running Win10 64-bit. FBIde has worked for years. I'm now getting the application error The application was unable to start correctly (0xc0000142). The last time I ran FBIde was probably 2 months ago, so there could have been many Win updates - too many for undo. Download...

Go to advanced search