can't unzip over older version of fbc

For other topics related to the FreeBASIC project or its community.
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 8:06

Need to download latest version of FreeBasic Compiler to unzip over version that came with FBIDE but the only option is FreeBASIC-1.07.3-win64.7z

When I use BreeZip and choose C:/FreeBASIC as the folder to extract to, it just creates another folder within C:/FreeBasic called FreeBASIC-1.07 with another folder inside that called FreeBASIC-1.07.3-win64. It doesn't unzip fbc over the version that came with FBIDE that is in C:/FreeBasic

Is there any fbc version that is in the form of a .zip file?

I have to run FBIDE with the old version of fbc by selecting the FBIDE icon with the right mouse button and choosing "run as administrator" which was suggested to me by some tech guy at a retail store but even he couldn't figure out why I had to do it that way for FBIDE.
Last edited by BasicCoder2 on Mar 13, 2021 10:13, edited 1 time in total.
Cretin Ho
Posts: 182
Joined: Feb 04, 2021 13:01

Re: can't unzip over older version of fbc

Postby Cretin Ho » Mar 13, 2021 8:54

Just ditch FBIDE and use WinFBE suite, this will save you a lot of unneeded troubles.

viewtopic.php?f=8&t=25215

I hope I could teamview into your machine but the fact is I can't. You know why your questions rarely received useful answers? Because we can't imagine what's going on on your computer and which exact problems you wanted to solve.

If you think WinFBE is bloated, then use whatever else you like, there are VisualFBEditor (viewtopic.php?f=8&t=27284), IUP_FB_EDITOR (viewtopic.php?f=8&t=26030), Poseidon-FB (viewtopic.php?f=8&t=23935).

Any of them is better than FBIDE. I admit I have never used FBIDE but all of the IDEs I mentioned allow you to use an arbitrary fbc version, just specify the correct path to fbc.exe (or fbc32.exe, fbc64.exe). Why on earth you still stick with an IDE that not allow you to select another compiler version and need to use tricks like unpacking a newer version to replace the old one?

As I know, that FBIDE also no longer be developed. Time to switch to a new one. From the screenshots of FBIDE I saw on the internet I think you should choose IUP_FB_EDITOR, it looks somewhat familiar.

If that FBIDE was developed before the introduction of UAC on modern Windows, of course it will need to be run as administrator. You are running an incompatible program on modern Windows, not updated to follow modern conventions. Time to switch to a new one, as I said above.
jj2007
Posts: 2144
Joined: Oct 23, 2016 15:28
Location: Roma, Italia
Contact:

Re: can't unzip over older version of fbc

Postby jj2007 » Mar 13, 2021 9:24

BasicCoder2 wrote:the only option is FreeBASIC-1.07.3-win64.7z
I don't know BreeZip but 7zip definitely knows how to open a .7z archive...

You can solve the drives problem by creating your own F: drive with subst, see How to make SUBST mapping persistent across reboots?

Google for subst windows 10 persistent to see more options.
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

Re: can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 9:41

@Cretin Ho

Not all that interested in having to learn to use another editor as my needs are simple. It seems the more advanced editors are harder to learn to use than the simple ones. I used to use GRASP when I first started learning Java. They have "upgraded" it to something I cannot figure out how to use.

Maybe fbc 0.23.0 version that came with the FBIDE download will be sufficient however that version doesn't seem to recognize the boolean keyword.

When I exit FBIDE it also pops up an error window of the same admin glitch,

FBide Error
(x) can't open file 'c:\FreeBasic\IDE/history.ino'(error 5: access is denied.)

@jj2007

BreeZip opens the 7z file ok it just doesn't open the fbc .exe over the previous version of fbc instead it creates another separate folder (actually two separate folders) with the folder it is extracted to.
dodicat
Posts: 6949
Joined: Jan 10, 2006 20:30
Location: Scotland

Re: can't unzip over older version of fbc

Postby dodicat » Mar 13, 2021 10:38

Basiccoder2
Just expand fbc somewhere and cut and paste the whole distribution to a folder of your choice.
You can point your fbide to the new fbc.exe, or you can get another fbide and use it instead.
I never would think of unzipping over an older fb, If I don't want the old fbc I just bin it.
I use 7zip.
I never put freebasic or fbide directly on the C drive (a personal choice).
I use a folder on my desktop for everything freebasic, and keep shortcuts to my fbides on the desktop.
I have an fbide for 32 bits and another for 64 bits.
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

Re: can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 17:14

@dodicat
Just expand fbc somewhere and cut and paste the whole distribution to a folder of your choice.
You can point your fbide to the new fbc.exe, or you can get another fbide and use it instead.


The folder it created when .7z was expanded was fine as I can always rename it.

I had the idea to copy the FreeBASIC folder from my old computer onto an SD card. When I plugged it into the new computer it seemed to work but in fact uses the .exe icon for both .bas and .exe files. You can load the .bas files into the FBIDE but you cannot double click a .bas file with the .exe icon to start up FBIDE with that source code. When you click the icon it asks: "How do you want to open this .bas file?" giving the option "C:\FreeBasic\FBide""%1" If I click [ok] it just keeps repeating the question.

update: Just extracted the FBIDE again and now the fb icon appears with a .bas file
I changed the compiler path in the FBIDE settings and the programs recognize the boolean variable.


update2: So I decided to delete the C:\FreeBASIC folder but the associated .bas icon vanished and the problem below reappeared.

Image
Last edited by BasicCoder2 on Mar 13, 2021 17:49, edited 2 times in total.
Cretin Ho
Posts: 182
Joined: Feb 04, 2021 13:01

Re: can't unzip over older version of fbc

Postby Cretin Ho » Mar 13, 2021 17:26

BasicCoder2 wrote:@Cretin Ho

Not all that interested in having to learn to use another editor as my needs are simple.

I know this so I pointed you to IUP_FB_EDITOR. This is the most simple, very familiar user interface to FBIDE users. Please give it a try. It's a portable app, no need to install. But as I see you need shell integration, you could try to set open .bas file with IUP_FB_EDITOR.

At least give it a try, please. The name of it already tell you, it's an editor, not a full featured IDE like WinFBE, it's very simple. This will save you from a lot of troubles messing with the old FBIDE.

BTW, moving an installed app to SD card is not a good idea. I guest FBIDE is not portable app but installed using an installer, because I saw there is shell integration, indicating an installed app. Moving an installed app to SD card of course will render shell integration stopped working or malfunctioning.
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

Re: can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 17:41

@Cretin Ho
Is that Paul Squires' editor which I seem to read works like VB?
I don't want windows specific code as my programs are very simple and I want them to also compile and run on Linux.
I actually use Geany on the Linux RPi and it works without problems.
dodicat
Posts: 6949
Joined: Jan 10, 2006 20:30
Location: Scotland

Re: can't unzip over older version of fbc

Postby dodicat » Mar 13, 2021 18:33

fbide is not installed in any way, you just unzip it and use it.
basiccoder2.
You can renew your .bas extension with your new fbide.exe surely.
Personally I don't tie .bas to fbide.exe, I have two fbides, one for 32 bits and 64 bits.
Wordpad opens any .bas file I click on, it is just a personal preference.
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

Re: can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 19:03

@dodicat
fbide is not installed in any way, you just unzip it and use it.

I download FBIDE + FreeBASIC installer and extract it and double click the result getting a setup wizard which I assume associates the FBIDE icon with the program.
"This will install FBIde 0.4.4r4 + FreeBASIC on your computer"
Image
This results in any file with the .bas extension having the FBIDE icon.
Which if double clicked will fire up the FBIDE loaded with that file.
Image
dodicat
Posts: 6949
Joined: Jan 10, 2006 20:30
Location: Scotland

Re: can't unzip over older version of fbc

Postby dodicat » Mar 13, 2021 20:03

OK basiccoder2.
I have never used that set up.
Isn't fbc.exe old in that setup? Maybe it has been updated, I use the latest fbc from the news section of the forum.
1.07.3
BasicCoder2
Posts: 3738
Joined: Jan 01, 2009 7:03
Location: Australia

Re: can't unzip over older version of fbc

Postby BasicCoder2 » Mar 13, 2021 21:07

Yes it is fbc 0.23.0 but it does set everything up. I was told years ago to simple extract the latest version over it and that used to work.
However maybe I can figure out how to download FBIDE and fbc separately and connect them up with the icon association working.
I just down loaded and extracted the FBIDE into its own folder and linked it to the fbc in another folder but when I tried to save a test program in the same folder I just extracted the FBIDE I still get this glitch in a pop a window.
"You don't have permission to save in this location. Contact the administrator to obtain permission." Without of course telling you how to contact the administrator!!
So I just have to run everything from the SD card as that seems to work. I cannot however delete the other FBIDE without losing the icon association.
Last edited by BasicCoder2 on Mar 13, 2021 21:25, edited 1 time in total.
Cretin Ho
Posts: 182
Joined: Feb 04, 2021 13:01

Re: can't unzip over older version of fbc

Postby Cretin Ho » Mar 13, 2021 21:13

BasicCoder2 wrote:@Cretin Ho
Is that Paul Squires' editor which I seem to read works like VB?
I don't want windows specific code as my programs are very simple and I want them to also compile and run on Linux.
I actually use Geany on the Linux RPi and it works without problems.

No. If you paid any attentions to my post, you will not said so.
Cretin Ho wrote:Just ditch FBIDE and use WinFBE suite, this will save you a lot of unneeded troubles.

viewtopic.php?f=8&t=25215

I hope I could teamview into your machine but the fact is I can't. You know why your questions rarely received useful answers? Because we can't imagine what's going on on your computer and which exact problems you wanted to solve.

If you think WinFBE is bloated, then use whatever else you like, there are VisualFBEditor (viewtopic.php?f=8&t=27284), IUP_FB_EDITOR (viewtopic.php?f=8&t=26030), Poseidon-FB (viewtopic.php?f=8&t=23935).

Any of them is better than FBIDE. I admit I have never used FBIDE but all of the IDEs I mentioned allow you to use an arbitrary fbc version, just specify the correct path to fbc.exe (or fbc32.exe, fbc64.exe). Why on earth you still stick with an IDE that not allow you to select another compiler version and need to use tricks like unpacking a newer version to replace the old one?

As I know, that FBIDE also no longer be developed. Time to switch to a new one. From the screenshots of FBIDE I saw on the internet I think you should choose IUP_FB_EDITOR, it looks somewhat familiar.

If that FBIDE was developed before the introduction of UAC on modern Windows, of course it will need to be run as administrator. You are running an incompatible program on modern Windows, not updated to follow modern conventions. Time to switch to a new one, as I said above.

If you are too hurry to read my somewhat long post, here is the link to it:
viewtopic.php?f=8&t=26030

BTW, Geany is also available on Windows.
Cretin Ho
Posts: 182
Joined: Feb 04, 2021 13:01

Re: can't unzip over older version of fbc

Postby Cretin Ho » Mar 13, 2021 21:17

BasicCoder2 wrote:Yes it is fbc 0.23.0 but it does set everything up. I was told years ago to simple extract the latest version over it and that used to work.
However maybe I can figure out how to download FBIDE and fbc separately and connect them up with the icon association working.

I was right after all. You used an installer. If you have to figure how to set things up anyway, why don't try something new? Too afraid? Why? Is there any dragons? Just have a look at it: viewtopic.php?f=8&t=26030

This will be my last reply if you still want to use your FBIDE. I can't talk with clueless naysayers that doesn't even have a look at what I'm pointing them to. Bye.
aurelVZAB
Posts: 428
Joined: Jul 02, 2008 14:55
Location: Croatia
Contact:

Re: can't unzip over older version of fbc

Postby aurelVZAB » Mar 13, 2021 22:14

of course if is intalled then you must remove installation
clean registry
then unzip or whatever else you want .

Return to “Community Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest