FBC on Puppy

Linux specific questions.
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

FBC on Puppy

Postby aurelVZAB » Jul 27, 2021 21:46

Ok
as i said before i download binary and add it to distro then sudo install.sh and
voila FB is installed in /usr/local
well then i figure that i dont have and editor ...
ok i will use one from fb forum

so which one is small and fast ..please not Geany!
Kuan Hsu
Posts: 532
Joined: Sep 16, 2007 15:12
Location: Taiwan

Re: FBC on Puppy

Postby Kuan Hsu » Jul 28, 2021 16:11

aurelVZAB wrote:Ok
as i said before i download binary and add it to distro then sudo install.sh and
voila FB is installed in /usr/local
well then i figure that i dont have and editor ...
ok i will use one from fb forum

so which one is small and fast ..please not Geany!

I test poseidonFB on FossaPup64 9.5, it seems OK
But because package the IUP and GTK2 libraries, it needs 7.7MB -- poseidonFB_x64_rev460_GTK2.AppImage
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Jul 28, 2021 17:24

Thanks Kuan
My puppy is Saluki 32bit so i doubt that this version will work.
In fact i cannot beleive that nobody from linux experts around don't build remaster with FreeBasic preinstalled yet.
If all goes well
1.need better Web browser ...PaleMoon or Midori
2.Decent code editor or IDE that enable normal use of FB

i will try to make remaster of this one becuase this distro have remastering tool with many capability.
and is small and fast
Kuan Hsu
Posts: 532
Joined: Sep 16, 2007 15:12
Location: Taiwan

Re: FBC on Puppy

Postby Kuan Hsu » Jul 29, 2021 1:28

It not work because of 32bit

IUP didn't released pre-compiled libraries since v3.22, I think I need:
(1) Install gcc(v4.6 or 4.8?) and gtk2-dev
(2) Download IUP3.27 sources and try to build 32bit IUP libraries
(3) Install dmd compiler and build poseidonFB

Let me test later......
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Jul 29, 2021 6:16

no need to hurry
it is just a experiment
caseih
Posts: 1752
Joined: Feb 26, 2007 5:32

Re: FBC on Puppy

Postby caseih » Jul 29, 2021 14:34

If you're already running a minimalist Linux distribution, then you really need to just use a minimalist editor, terminal-based only. Pick your poison: joe, nano, or vim. Probably there are others. For me, vim is all I have used for 20 years. A steep learning curve, but well worth it. I don't have much patience or need for the fancy IDEs, unless I'm working in C#, Java, or C++ with Qt.
Kuan Hsu
Posts: 532
Joined: Sep 16, 2007 15:12
Location: Taiwan

Re: FBC on Puppy

Postby Kuan Hsu » Jul 29, 2021 18:13

aurelVZAB wrote:no need to hurry
it is just a experiment

Just for fun:
https://www.mediafire.com/file/kb7n99zu ... it.7z/file
(1) Put the libiup.so and libiup_scintilla.so in "File System" -> /lib
(2) Run ./poseidonFB
Image
7/31 updated:
Add AppImage Package( x86/GTK2 ): https://bitbucket.org/KuanHsu/poseidonfb/downloads/

I couldn't install gcc and gtk2.0-dev to build IUP on Saluki , so I built IUP and poseidonFB on Linux mint 13 maya( base on Ubuntu12.04 ), but back to Saluki, I got an glibc 2.10.1 issue( linux mint 13's glibc is ver2.11), so I re-built IUP on Linux mint 8( base on Ubuntu9.10) success and got a dmd compiler libc problem.....what the......
Finally, the IUP libraries is built on Liunx mint 8 and poseidonFB is built on Linux mint 13, then combile back to test on Saluki...^^
Last edited by Kuan Hsu on Jul 31, 2021 6:36, edited 1 time in total.
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Jul 30, 2021 6:53

Ok i will try
hungnguyengia
Posts: 65
Joined: Jul 01, 2021 7:53

Re: FBC on Puppy

Postby hungnguyengia » Jul 31, 2021 14:48

I'm using Fatdog64 Linux, a cousin of Puppy. It used to be based on Slackware. Now independently developed but still resemble Slackware in many aspects. The following that worked:

Make a symbolic link of libtinfo.so.5 to libncursesw.so

PoseidonFB works. I tried to use the AppImage version. Works flawlessly.

Geany is preinstalled and of course works. Why you afraid Geany?

VisualFBEditor works but not really reliable. I can't change the editor font nor I'm able to run console app in terminal. You have to install gnome-terminal, mate-terminal, lx-terminal, xfce4-terminal or something compatible with them in order for it to work. I tried to use xterm and the default terminal urxvt, both do not work. You have to make another symbolic link of libtinfo.so.6 to libncursesw.so and have to use the GTK2 version. If you want to use the GTK3 version you have to install GTK3 from GSlapt.

IUP_FB_Editor worked, too. You have to download the last version of IUP that support GTK2 from there:

https://sourceforge.net/projects/iup/fi ... Libraries/

Choose the Linux 3.5 64 bit if you are on a 64 bit kernel like me.

Extract the archive and copy libiup.so and libiup_scintilla.so into IUP_FB_Editor's directory. This editor only needs these two libraries, not the whole IUP so do not need to install IUP. Run it with this command:

LD_LIBRARY_PATH=. ./fbnp

The reason for LD_LIBRARY_PATH is Linux doesn't search the current directory for libraries like Windows.

If you used the GTK3 build of IUP then you have to install GTK3 from GSlapt like with VisualFBEditor.

My only recommendation is to install a better terminal than urxvt, any of these would work: gnome-terminal, mate-terminal, lx-terminal, xfce4-terminal. Hope it helps.
hungnguyengia
Posts: 65
Joined: Jul 01, 2021 7:53

Re: FBC on Puppy

Postby hungnguyengia » Jul 31, 2021 14:54

You could even do this. Open SFS Manager and download the latest version of Wine. Since Wine is 32 bit you have to install the 32 bit compatibility library, too. Load these two SFS and configure Wine like this:

# run-as-spot winecfg
# run-as-spot winetricks fontsmooth=rgb

Why use the script run-as-spot? Because you shouldn't run Wine app as root.

Then you could download PaulSquires' WinFBE (viewtopic.php?f=8&t=25215) or VisualFreeBASIC (viewtopic.php?f=8&t=28522). Run them with the same run-as-spot script.

You could try the Windows edition of any FB editors available here, too. You could run console app without any problems and don't have to deal with the terminal troubles of the Linux based ones. Of course, you will have to use the Windows release of FBC, too.
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Jul 31, 2021 22:23

hung

first i am not afraid of Geany i simply don't like this thing.
second FatDog64 dont have nothing with old Saluki Puppy linux
... i dont have time to mess up with linux like you
personaly i tried IUP on windows and heck is not good as winapi but on linux well might be
another thing Kuan tried to turn on linux ...my point is to use minimal as possible linux distro that i can ran from wm or
usb stick to test some code of FreeBasic ,and yes that part work on saluki i used fbc105
who knows maybe i will find some nice piece of code in C or C++ which use scintilla.h and compile it under puppy
but that is not my main OS ..i still lke and use Windows
hungnguyengia
Posts: 65
Joined: Jul 01, 2021 7:53

Re: FBC on Puppy

Postby hungnguyengia » Aug 01, 2021 8:13

aurelVZAB wrote:hung

first i am not afraid of Geany i simply don't like this thing.
second FatDog64 dont have nothing with old Saluki Puppy linux
... i dont have time to mess up with linux like you
personaly i tried IUP on windows and heck is not good as winapi but on linux well might be
another thing Kuan tried to turn on linux ...my point is to use minimal as possible linux distro that i can ran from wm or
usb stick to test some code of FreeBasic ,and yes that part work on saluki i used fbc105
who knows maybe i will find some nice piece of code in C or C++ which use scintilla.h and compile it under puppy
but that is not my main OS ..i still lke and use Windows

Use CudaText, it runs fine on any Linux, only needs to set python library path: https://cudatext.github.io/
I smell a lot of hate here. Hate me? OK, man. BTW, I use ROSA Linux on HDD and Fatdog64 on my USB, and also have Windows 7 on laptop. I'm not messing with Linux. Each served their own purproses. Best regards.
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Aug 02, 2021 5:30

hate ???
what kind of hate???

no i just don't want to wasting my free time on linux this and that
downloading this ,,modifaying that ,,, programming on Windows is 10 times easier .
python...oh no...
Well BaCon looking great but require bumping and jumping to get it work .
aurelVZAB
Posts: 472
Joined: Jul 02, 2008 14:55
Location: [url]https://www.facebook.com/groups/470369984111370[/url]
Contact:

Re: FBC on Puppy

Postby aurelVZAB » Aug 11, 2021 19:58

well
i am not impressed with speed of Puppy ,,somehow is slowish
but when i put 4MLinux on usb and ran this distro that one simply fly
how is possible that larger distro work faster then small puppy ?

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 2 guests